Philips: Logs am TV-Service-Port (SERV.U) mithilfe eines USB-UART-Adapters auslesen (Anleitung)

Allgemeines rund um Philips (Sonicare, TV, AVM, Hue, ... )
Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)
  • Autor
    Antworten
  • #193950 Antworten
    Benjamin
    Gast

    Moin,
    vielen Dank, die email ist verschickt. Der Netzstecker war schon über 24 Stunden gezogen.
    Gruß Ben

    #194300 Antworten
    Christoph
    Gast

    Vielen Dank! Habe mein Philips PFL55 8007k fast aufgegeben und dank des Forums, wiederbelebt!

    Er hatte keine Funktion und nach mehreren Minuten blinkte die Led 2x kurz hintereinander.. Nach mehrmaligen Heißfönen auf der CPU, hatte ich wieder erste Lebenszeichen, aber leider kein Bild.

    Dann bin ich auf den Beitrag für den selbstgebastelten Serv.U Stecker gestoßen und hab Ihn dank der affiliate Links direkt bestellt und zusammengebastelt. Angeschlossen und mit der “Serial”-App (kurz googlen) in den Logs gesehen, das alles Funktional schien und die richtigen Programme/Apps gestartet worden sind. Nur ohne Bild.

    Skeptisch, wie ich als Software-Entwickler bin, schien das Mainboard funktional. Also muss es an der Verbindung zwischne Mainboard + TV liegen (oder Bildschirm kaputt).

    Fazit: Es hat sich rausgestellt, das ich das dicke Flachbandkabel beim ersten Herausziehen direkt am Kabelende beschädigt habe. Es gibt auf beiden Seiten leichte Einbuchtungen, damit das Kabel besser in die Buchse einrastet und eine Seite davon ist abgerissen. Beim beim einstecken hab ich das Kabel scheinbar um 1-2 Pins verrutscht eingesteckt und hatte deswegen kein Bild.

    Hab das Kabel herausgezogen und zum Anschlag auf die gegenpberliegende Seite in der Buchse gesteckt und das Gerät läuft wieder!

    #194301 Antworten
    Toengel
    Verwalter

    Tachchen,

    topp!

    Toengel@Alex

    #197008 Antworten
    Steffen
    Gast

    Hi, vielen Dank für die tolle Anleitung! Mein 65OLED803 hat zwar keine Klinkenbuchse, sondern einen 3 poligen JST Konnektor (GND in der Mitte, RX unten).

    Der TV rebootet immer 30sec bis 2min nachdem er angefangen hat ein Bewegtbild anzuzeigen. Im Log erscheint dann immer folgender Eintrag:

    [ 243.479539] <PQCTRL><HandleErrDetection:1058]> pqdrivers_tcon_ctrl: OledTconErrDetMsgHandler Error detected m_ErrDetCounter:0
    [ 243.719104] <PQCTRL><HandleErrDetection:1058]> pqdrivers_tcon_ctrl: OledTconErrDetMsgHandler Error detected m_ErrDetCounter:1
    [ 243.959474] <PQCTRL><HandleErrDetection:1058]> pqdrivers_tcon_ctrl: OledTconErrDetMsgHandler Error detected m_ErrDetCounter:2
    [ 244.199439] <PQCTRL><HandleErrDetection:1058]> pqdrivers_tcon_ctrl: OledTconErrDetMsgHandler Error detected m_ErrDetCounter:3
    [ 244.439195] <PQCTRL><HandleErrDetection:1049]> pqdrivers_tcon_ctrl: OledTconErrDetMsgHandler Error detected LOG FATAL
    [ 244.447073] <PQCTRL><mpqsocctrl_display_notifyErrors:2033]> Device[OLED TCON], listner[d0e7ed40] Factory[0]
    [ 244.458007] opcdisplaytech=1
    [ 244.459770] [Error]PQSOCCTRLP_ERROR_DEVICE_OLEDTCON Counter[1] => TV Reboot!
    [ 244.468726]
    [ 244.468726] ==>PDWNC_Reboot<==
    [ 244.471247] CPU: 0 PID: 1575 Comm: MLVdo_thread Tainted: P O 3.10.79 #1
    [ 244.478768] [<c0015c40>] (unwind_backtrace+0x0/0xe8) from [<c0012c38>] (show_stack+0x20/0x24)
    [ 244.487264] [<c0012c38>] (show_stack+0x20/0x24) from [<c05ced68>] (dump_stack+0x20/0x28)
    [ 244.495853] [<c05ced68>] (dump_stack+0x20/0x28) from [<bf1ced34>] (PDWNC_Reboot+0x38/0x7c [mtk_mod])
    [ 244.505399] [<bf1ced34>] (PDWNC_Reboot+0x38/0x7c [mtk_mod]) from [<bf0d60fc>] (_ErrorHandler_Body+0xec/0x124 [mtk_mod])
    [ 244.516248] [<bf0d60fc>] (_ErrorHandler_Body+0xec/0x124 [mtk_mod]) from [<bf5ad560>] (mpqsocctrl_display_notifyErrors+0x9c/0xcc [mtk_mod])
    [ 244.528771] [<bf5ad560>] (mpqsocctrl_display_notifyErrors+0x9c/0xcc [mtk_mod]) from [<bf5aed70>] (pqsoccommon_mglue_infra_err_onError+0x9c/0x110 [mtk_mod])
    [ 244.542684] [<bf5aed70>] (pqsoccommon_mglue_infra_err_onError+0x9c/0x110 [mtk_mod]) from [<bf609550>] (kernel_glue_Create+0x730/0xb94 [mtk_mod])
    [ 244.555640] [<bf609550>] (kernel_glue_Create+0x730/0xb94 [mtk_mod]) from [<bf60b5c8>] (pqdrivers_oledtcon_ctrl_backgroundTask+0x308/0x64c [mtk_mod])
    [ 244.568806] [<bf60b5c8>] (pqdrivers_oledtcon_ctrl_backgroundTask+0x308/0x64c [mtk_mod]) from [<bf5ac5c4>] (mpqsocctrl_display_event+0x12c/0xf1c [mtk_mod])
    [ 244.582623] [<bf5ac5c4>] (mpqsocctrl_display_event+0x12c/0xf1c [mtk_mod]) from [<bf5a8888>] (pqsoccontrolP_Event+0x2c8/0x2ec [mtk_mod])
    [ 244.594707] [<bf5a8888>] (pqsoccontrolP_Event+0x2c8/0x2ec [mtk_mod]) from [<bf0dd95c>] (DRVCUST_VideoMainloop+0x88/0x100 [mtk_mod])
    [ 244.606487] [<bf0dd95c>] (DRVCUST_VideoMainloop+0x88/0x100 [mtk_mod]) from [<bf1a593c>] (vApiVideoMainloop+0xbc8/0xc50 [mtk_mod])
    [ 244.618152] [<bf1a593c>] (vApiVideoMainloop+0xbc8/0xc50 [mtk_mod]) from [<bf1a4148>] (NptvMainLoop+0xb8/0xd0 [mtk_mod])
    [ 244.628916] [<bf1a4148>] (NptvMainLoop+0xb8/0xd0 [mtk_mod]) from [<bf32cb1c>] (ThreadProc+0xa4/0xa8 [mtk_mod])
    [ 244.638433] [<bf32cb1c>] (ThreadProc+0xa4/0xa8 [mtk_mod]) from [<c004ec4c>] (kthread+0xbc/0xc8)
    [ 244.646526] [<c004ec4c>] (kthread+0xbc/0xc8) from [<c000e9d8>] (ret_from_fork+0x14/0x20)
    Boot-set res5 0

    Hat jemand eine Idee woran das liegen könnte? Mainboard / T-Con / Power Supply?

    Vielen Dank und viele Grüße

    Steffen

    #197009 Antworten
    Toengel
    Verwalter

    Tachchen,

    da öfter T-Con vorkommt, würde ich jetzt sagen, dass damit etwas nicht stimmt.

    Bootet die Kiste auch, wenn du ein Werksreset gemacht hast?

    Softwareseitig könntest du probieren den aktuellen upgrade_loader einmal zu installieren. Aber so richtig glaube ich nicht daran.

    Toengel@Alex

    #197016 Antworten
    Steffen
    Gast

    OK, danke fuer die schnelle Antwort.

    Werksreset aendert leider nichts, ebenso upgrade_loader.

    Dann bestelle ich mir mal ein T-Con Board.

    Gruesse

    Steffen

Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)
Antwort auf: Philips: Logs am TV-Service-Port (SERV.U) mithilfe eines USB-UART-Adapters auslesen (Anleitung)
Deine Information:




Die Kommentieren ist durch reCAPTCHA geschützt und es gelten die Datenschutzbestimmungen und Nutzungsbedingungen von Google.